• Home
  • Get help
  • Ask a question

#154 – Everything works fine except the comments on my blog

Posted in ‘weeblrAMP’
This is a public ticket. Everybody will be able to see its contents. Only enter usernames, passwords or any other sensitive information in the Private information field.
Sunday, 12 May 2019 19:56 UTC
dragonfroid
 Hello,

First of all, thank you for your plugin that I love.

I have a problem: everything works fine except the comments. On the AMP version of my blog (exemple : a link in "private information"), the comments you leave are not displayed. Do you know why?

Thank you!
Monday, 13 May 2019 07:24 UTC
wb_weeblrpress
HI

Are those the regular WP comments? I suspect the problem comes from using A Captcha system and an "Agree to terms" button. This is not standard and the plugin you use for that is probably not AMP compatible:

- AMP has only been accepting reCaptcha for a few days and we do not have support for it at the moment.
- the "agree to terms" button would require custom coding to be implemented on AMP

I would suggest disabling on AMP pages (see Comments and plugins section of weeblrAMP configuration) the plugin you use for this custom comments form.

Best regards
 
Monday, 13 May 2019 13:35 UTC
dragonfroid
Hi,
I've done that but it doesn't work :(
Monday, 13 May 2019 13:36 UTC
wb_weeblrpress
Hi

Are those the regular WP comments?


What plugin do you use? how do you add this Captcha and that Agree to terms button?

Best regards
 
Monday, 13 May 2019 14:24 UTC
dragonfroid
Yes, it is regular WP comments.
I use iThemes Security, but i desactivated it as u said.
Monday, 13 May 2019 14:38 UTC
wb_weeblrpress
Hi

Yes, it is regular WP comments.
WP Comments does not have reCaptcha so it cannot be just WP Comments.

I have just checked again and can see now that Captcha and Agree to terms are not there anymore. So I did more testing and found that there is indeed a problem when posting the comment to your site:



So it seems something on your server is blocking the access to our AMP comment php file. You disabled iThemes security but you likely have another level of security in place here. Things to check are:

- your .htaccess file: it might be locking up files other than WP own files to receive data
- any security related extension you might be using
- any security service you might be using.

Those should be set to allow POST access to /wp-content/plugins/weeblramp/public/amp-comments-post.php

Best regards
 
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.