• Home
  • Get help
  • Ask a question

#63 – PHP7 Compatibility

Posted in ‘weeblrAMP’
This is a public ticket. Everybody will be able to see its contents. Only enter usernames, passwords or any other sensitive information in the Private information field.
Thursday, 05 April 2018 16:27 UTC
steve.silenzio
 Is weeblrAMP php7+ compatible? Running the WPEngine PHP Compatibility Checker throws 3 warnings and 1 error.

FILE: wp-content/plugins/weeblramp/vendor/weeblr/wblib/vendor/w-shadow/vendor/ParsedownLegacy.php
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
FOUND 1 ERROR AFFECTING 1 LINE
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
1412 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------


FILE: wp-content/plugins/weeblramp/vendor/weeblr/wblib/vendor/joomla/string/src/StringHelper.php
----------------------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 3 WARNINGS AFFECTING 3 LINES
----------------------------------------------------------------------------------------------------------------------------
22 | WARNING | INI directive 'mbstring.internal_encoding' is deprecated since PHP 5.6
23 | WARNING | INI directive 'mbstring.http_input' is deprecated since PHP 5.6
24 | WARNING | INI directive 'mbstring.http_output' is deprecated since PHP 5.6

Can this error be safely ignored? Or is it legitimate?

Also, are the warnings from backwards compatibility functions? The plugin states "This tool cannot detect unused code paths that might be used for backwards compatibility, potentially showing false positives." and I've seen some similar errors in other plugins, so same question, safe to ignore?

Thanks!
 
Thursday, 05 April 2018 17:44 UTC
wb_weeblrpress
Hi

There is strictly no issue for PHP 7 compatibility, these warnings and specifically the error can be ignored.
We will update to more recent libraries when available, but the ParseDown Legacy lib is not used by weeblrAMP, it's just part of another library that we use.

Best regards

 
Friday, 20 April 2018 05:34 UTC
system
This ticket has been automatically closed. All tickets which have been inactive for a long time are automatically closed. If you believe that this ticket was closed in error, please contact us.
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.